It’s an old version and is not supported anymore, only the following browsers are supported

  • Windows : Chrome, Firefox, Edge
  • MacOS : Safari, Chrome, Firefox
  • Linux : Chromium
  • Mobile : works normally on any kind of browser.